QNX IDE Projectsand Build FAQ#

How can automated builds be set up with 4.5?#

1) If you are using Makefile Projects simply call make from project directory, you have to create a super
makefile to build al required projects (can create a super project for that too)

2) Using of container projects. This option could be convenient for those who use a big code base. Container
isaholder of various projects (among them could be other containers as well). It is the user's decision on how
to combine projects into container. For example, third-party service libraries could be assembled in asingle
container. Each container has a set of different build configurations (this is almost the same as assigning make
targets such as debug, release etc.). To build the whole workspace just launch aroot container build specifying
configuration. This structure should be mirrored into command line build. To provide this, insert special make
fileinto top container's root directory The content looks like that:

<configuration_1> :
cd ../Child_Container_1 ; make <target name>
cd..

cd ../Child_Project_k ; make <target name>

<configuration_n> :

3) Using mksbp utility

4) Using make for QN X Projects. In this case super makefile has to contain some setup which includes setting
"project path" macros. The recommended way isto create an extrafile with this definition (here mylib isthe
project name):

* If your project and dependency live in workspace

o PROJECT_ROOT_mylib=$(PROJECT_ROOT)/../libl
* |f your project and dependency live outside workspace

o PROJECT_ROOT_mylib=F:/libs/mylib

(repeat thisfor every project)

Then add to this extra make file launch of you "root" make file or add environment variable
MAKEFILE=<extra-makefile>.

If you build several IDE project you have to create an additional makefile (can be the same as one with
variables) and call make in every project, i.e.

PROJECT_ROOT_mylib=F:/libs/mylib
PROJECT_ROOT_myapp=F:/libs/myapp
all:
cd ${ PROJECT_ROOT_mylib}; make all
cd ${ PROJECT_ROOT_myapp} ; make all

How can | create M akefile Project in IDE 4.5?7#

New->C Project opens a C Project Wizard Select Makefile->Empty Project Select QNX QCC on the right
(important!)



QNX QCC toolchain set environment variables, such as CC, LD etc. They are automatically corrected when
you switch compiler or build variant from Settings page of project properties. If you don't want these variables
to be defined you can select and undefine them from the Environment tab.

What isthe difference between Managed C project with QNX toolchain and QNX
Project?#

Managed C project (MBS) with QNX toolchain can be used in similar way as QNX Project. They are both
managed projects. QNX Project is based on gnx recursive makefiles, when you change setting of QNX Project
you modifying a makefile for this project. If you change makefile manually - QNX Project would read and
recognize this change (it may be limited to known build macros). Managed project stores all setting in XML
and they cannot be changed outside of IDE. Y ou can pick builder for Managed project - internal builder,

or external make builder. In the second case, makefiles would be generated that represent build process for
this project, but you cannot change those makefiles. Besides that, MBS has a bit more modern Ul and more
flexibility for project structure (you can exclude some files to be compiled for example). On the other hand
QNX Project has very good build variants structure which is nice when you are building for 5 platforms at the
sametime.

What isrecommended way to organize project structurefor |DE?#

See the technical article, "Projects, Building, and the IDE".

Wheredoesa" QNX Project” storeits metadata?#

QNX Project properties are mostly stored directly in makefiles, in particular "common.mk”. Additional macro
and functions stored in internal makefile ".gnx_internal.mk". Settings for current active builds are stored in
workspace metadata, outside of the project. If you want it to be stored with project you can check " Share all
project properties’ - in this case it would be stored in .cproject file inside the project folder.

Can | create projectstargeting something other than the QNX OSor can | use different
compiler ?#

Yes, QNX IDE is based on Eclipse CDT which alow to create project for any target. You need to install
appropriate toolchain on your host and you may need to create atoolchain definition from IDE. Search CDT
newsgroup for thistopic.

How do | change the default settings for new proj ects?#

To enable QN X Toolchain as preferred toolchain for Makefile and Managed projects. * Open Window-
>Preferences...

C/C++->New CDT project wizards

Select Makefile project->Empty Project
Select QNX QCC

Click on button "Make toolchain(s) preferred”
Click OK.

If you are anticipating creating many new projects and they will have values different than the defaults, you can
change default settings for makefile projects:

* Window->Preferences...
o C/C++->New CDT project wizards->M akefile Project
 Go through tabs and pick defaults for your projects


http://community.qnx.com/sf/wiki/do/viewPage/projects.ide/wiki/ProjectsBuildAndIDE

For Qnx Projects:

» Window->Preferences...
* QNX->New Project
» Go through tabs and pick defaults for your projects

How to create keyboard shortcut for Build?#

To fast access to Build command define a keyboard shortcut (e.g. F6).

* Windows->Preferences...

» TypeKeysinfilter

o Select Keys

* Check Include unbound commands
» Type build in right panel filter
 Select Build Project

» Select Binding field

* Presskeystroke <F6>

 Click Apply

* Click Copy command

* Select C/C++ Editor in When combo box
 Select Binding field and press <F6>
 Click Apply again

How show line numbersin the C/C++ editor ?#

Open Window->Preferences
Type"line" infilter

Select Text Editors

Check Show line numbers
Click OK

Isit possibleto configurethe IDE to add a" Build Project” icon on the toolbar ?#

To show build button in C/C++ perspective (or any other perspective) from bar menu select "Windows-
>Customize Perspective->Commands' and check "Build Action Set".

How to create different build configuration in QNX Project?#

By default you have severa platform configurations, for each of them you have release and debug variant. Y ou
can create extra configurations for example to link with different libraries. Lets say you want configuration 1
link with library libMy1.s0 and configuration2 link with library libMy2.s0. To do that first select you platform,
for example x86 (In Project->Properties...->QNX C/C++ Project->Build Variants). Y ou have "debug" and
"release” inside. Add "release2" and "debug2" (by selecting "x86" and pressing Add button on the right).

Click on"Advanced" button at the bottom. ON the top right select x86 and "release”, in library tab pick Extra
Libraries from pull-down menu and add your library libMy1.s0. Same for debug. Same for release2 and debug2
but pick library libMy2.so this time. When you build you now would have 4 configurations.

Do | need to convert my project toa" Momentics style project” to usethe | DE?#

The IDE wants you to narrow down the scope of what it needs to know about (source, binaries etc) so you
need to create aproject _associated with your source/binaries and this project isinturn _associated with a



workspace. This project doesn't have to be in the workspace, it can be anywhere you want it to be. Here are
some options:

» Sourcelivesin aproject which lives in the workspace. Thisisthe default when you create a new project
or bring source into the IDE using Import from filesystem (which _can_do acopy, but doesn' t have to) or
using aversion control plugin

 Source lives somewhere in the filesystem and we want to overlay a project at that location. Y ou can
achieve this by creating a project and changing the default location from the workspace to the location of
the source.

 Source lives somwhere in the filesystem, but we don't want to create any metadata filesin that location. In
that case, create a project (in the workspace or elsewhere as in the previous scenario) that is empty. Then
create afolder in that project and make the folder location ‘point' to the source in the filesystem using the
">>Advanced" section of the dialog. Thisislike aunix symlink, but exists only in the IDE workspace.

See more on thistopic in Project, Build and IDE Article.

Do | need to convert my build processto match an | DE proj ect?#

The process of selecting a project type appears more complicated than it is. For _nearly _every type of existing
code with abuild process, you will want to choose the "Makefile Project” type. Why? Because this project type
just calls out to some external build program to build the source. Most of the time thisis'make’, hence the name
of the project, but it could be JAM, ANT, dmake, cons or any other builder.

If you have the luxury of starting your project from scratch, then the QNX Projects are interesting because they
allow you to build multiple processors (more generally 'variants,, including OSes) with a single build based on
the QN X recursive make framework. They won't ‘port’ well to other systems however. Managed Make Projects
are interesting because they provide afull IDE graphical control and configuration, familiar to those coming
from Visual Studio, and can really take advantage of the Eclipse frameowork (ie incremental compiles, links
etc) but are still relatively immature.

... and if you are never going to run your build from the IDE (I never say never), then the choiceis even
simpler: Standard Make al the time just to identify the source as " C/C++" source and help identify the binary
types. See more on thistopic in Project, Build and IDE Article.

Nothing is showing up anywhere, thisIDE thing istotally busted '#

Since one of the goals of the IDE isto simplify and automate work for developers, it needs to be told what to
do, there are two (per project and global default) settingsin particular that are important:

» The binary parser setting. This setting lets IDE tools (like the debug launcher) filter binary code from
source code. When you see the '‘Binary Parser’ task running in the progress bar, that is the background
thread that isiterating over the project content attempting to determine which files are binaries and which
are not. Thisiswhat provides the (virtual) content for the binaries folder in the Project Explorer view and
the content for the debug launcher file selection dialog when you select "Search” (vs Browse). If you don't
see anything in these places:

o a) The binary search has not come across anything yet and/or is not complete
o b) The binary parser is mis-configured, so go and check it out: Should be QNX ELF

* Indexer/Parser settings. Internal parser is used to parse C/C++ code and create internal database with
symbol references as well asto create internal syntax representation of the code, which is used for Syntax
Highlighting, Code Formatting, Navigation, Refactoring, Code Completion, also to show Call Hierarchy
and Type Hierarchy etc. If you using your own makefile thereis no way (well not right now) to figure out
which include paths and macros you are using for the build, and without this information parsing would
be badly broken and you may not do any of these things. Y ou have to configure your includes and macro
definition in Path and Symbols setting of Project Properties->C/C++ Build settings.


http://community.qnx.com/sf/wiki/do/viewPage/projects.ide/wiki/ProjectsBuildAndIDE
http://community.qnx.com/sf/wiki/do/viewPage/projects.ide/wiki/ProjectsBuildAndIDE

The debugger setting (Launch configuration in general). If code paths are not matching on host and the
machine it was build on you need to create Path Mapping in Source tab of launch configuration . If you
need environment variable set for your processincluding LD_LIBRARY PATH you haveto setitin
Environment tab. To load symbols from libraries Debugger needs to find libraries on the host side. You
need to set them in Shared Libraries tab of Debug tab (Shared Libraries tab of Tools for other gnx tools).

Library version hasto match on target and host with runtime soname for shared libraries. See more on that
topic at Debugger FAQ page.



http://community.qnx.com/sf/wiki/do/viewPage/projects.ide/wiki/DebuggerFAQ
http://community.qnx.com/sf/wiki/do/viewPage/projects.ide/wiki/IDEFAQ

