Project Home
Project Home
Wiki
Wiki
Project Information
Project Info
wiki4358: SDP_6.5.0_BSP_Info (Version 12)

SDP 6.5.0 BSP Information#

This page contains important information required to compile and package BSPs with the QNX Software Development Platform 6.5.0.


The 6.4.x information page can be found here.


6.5.0 Installation Notes


6.5.0 Interoperability #

Building 6.4.x BSPs with QNX SDP 6.5.0#

6.4.x BSPs should compile and work with QNX SDP 6.5.0. Below are the known generic issues with 6.4.x bsps. The release notes for the specific bsps will also be updated with specific known issues for that bsp. Please get the latest release notes for your bsp before attempting to compile it with SDP 6.5.0.

Some 6.4.x BSPs contain old versions of some header files which are included in the SDP 6.5.0. If you get compile errors in these files, try removing the files from the BSP itself and recompiling:

  • syspage.h

Due to compiler changes, some 6.4.x BSPs contain source files that no longer compile. Some errors and solutions are listed below:

  • File: init_cpuinfo.c
    • Error: offset to unaligned destination
    • Resolution: make a change similar to this in the set_ccr function:
--- trunk/hardware/startup/boards/edosk7780/init_cpuinfo.c	2009/04/08 01:47:35	217585
+++ trunk/hardware/startup/boards/edosk7780/init_cpuinfo.c	2009/06/01 14:04:50	222170
@@ -42,6 +42,7 @@
 	"or		%3, %0;\n"			\
 	"jmp	@%0;\n"				\
 	"nop;\n"					\
+	".align 2\n"					\
 	".La%=:\n"					\
 	"mov.l	%2, @%1;\n"			\
 	"nop;\n"					\
  • Error: hw/can.h: No such file or directory
    • Resolution: copy the file from prebuilt/public/hw/can.h to prebuilt/hw/can.h
  • Error: sys/can_dcmd.h: No such file or directory
    • Resolution: copy the file from prebuilt/public/sys/can_dcmd.h to prebuilt/sys/can_dcmd.h

libi2c-master.a compatibility issues:

  • if your pre-6.5.0 bsp contains a prebuilt libi2c-master.a then download this file and replace the libi2c-master.a with the appropriate one.

BSP's not compatible with 6.5.0:

  • Cavium CN57xx BSP is not compatible with 6.5.0. The resolution for this is being worked on.
  • IBM PowerPC 970F is not compatible with 6.5.0.
  • BSP's pre 6.4.0 may not be compatible with 6.5.0.
NOTE: 6.4.0 BSPs for e500-based boards cannot be used with SPE turned ON; you must use 6.4.1 versions of these BSPs instead

ARM V7 support#

Changing the variant of a BSP to V7 is not support since any binaries included in that BSP is not compatible with V7. Look for an updated 6.5.0 BSP for your platform here.

Building 6.5.0 BSPs with QNX SDP 6.4.x#

This is not supported, and upgrading to SDP 6.5.0 is required.


Available BSPs#

A complete list of BSPs can be found here.

Attachments:
Compressed file libi2c.zip [SDP_6.5.0_BSP_Info/libi2c.zip]



Active Tab Versions Inactive Tab - left sideAssociations Inactive Tab - left sideAttachments (1) Inactive Tab - left sideBack LinksInactive Tab - right side  
    Version From To Version Comment Created By
    Version 12 added libi2c section Bert Gemin  -  07/28/2010
    Version 11 added notes about reading release notes. Bert Gemin  -  06/16/2010
    Version 10 added v7 info Bert Gemin  -  04/15/2010
    Version 9 disable link for PowerPC Bert Gemin  -  04/13/2010
    Version 8 added 970 and pre6.4.0 Bert Gemin  -  04/13/2010
    Version 7 added can_dcmd.h note Bert Gemin  -  04/13/2010
    Version 6 Bert Gemin  -  04/13/2010
    Version 5 added can.h Bert Gemin  -  04/13/2010
    Version 4 added align error info. Bert Gemin  -  04/12/2010
    Version 3 update links. Bert Gemin  -  04/09/2010
    Version 2 added section on file removal Bert Gemin  -  04/07/2010
    Version 1 create Bert Gemin  -  04/07/2010