Jump to ID:
Core Development Tools

Project Home

Documents

Source Code

Discussions

Wiki

Project Info
Forum Topic - Linking GCC compiled library with QNX 6.4.0 tools: (5 Items)
   
 
 
Linking GCC compiled library with QNX 6.4.0 tools  
Hi,

I have a library generated with "arm-none-linux-gnueabi-gcc-4.1.2" tools. I want to link this with QNX tools. I am 
gettign errors like EABI version conflict.
Can I link GCC library like this?

D:/projects/h264dec/test/arm\libh264dec.a(nalucommon.o) has EABI version 4, but target C:/ide-4.5-workspace/h264dec/arm/
o-le/h264dec has EABI version 0 


Thanks,
Venkat
Re: Linking GCC compiled library with QNX 6.4.0 tools  
Venkatarao Patnaik Balivada wrote:
> Hi,
> 
> I have a library generated with "arm-none-linux-gnueabi-gcc-4.1.2" tools. I want to link this with QNX tools. I am 
gettign errors like EABI version conflict.
> Can I link GCC library like this?

No, the QNX toolchain uses the apcs-gnu ABI and does not follow the EABI 
. The two ABIs are incompatible so you will have to rebuild your library.

Regards,

Ryan Mansfield
Re: Linking GCC compiled library with QNX 6.4.0 tools  
Can I rebuild the library with GCC tools with some options to make it compatible? OR I need to rebuild the library with 
QNX tools?
Re: Linking GCC compiled library with QNX 6.4.0 tools  
Venkatarao Patnaik Balivada wrote:
> Can I rebuild the library with GCC tools with some options to make it compatible? OR I need to rebuild the library 
with QNX tools?

It should be possible to generate apcs-gnu code from your linux 
toolchain using -mabi=apcs-gnu. However, your toolchain has likely been 
configured only for aapcs-linux which means the libgcc and other target 
libraries will follow the EABI, and you will not be able to link  your 
library.

I strongly recommend using the QNX gcc toolchain to rebuild your library.

Regards,

Ryan Mansfield
Re: Linking GCC compiled library with QNX 6.4.0 tools  
Okay. Thanks Ryan