Jump to ID:
QNX Community FUSE Project

Project Home

Tracker

Documents

Tasks

Discussions

Reports

Wiki

Build & Test

Project Info
Forum Topic - Error in building fuse: Page 1 of 4 (4 Items)
   
 
 
Error in building fuse  
Hi,
I am following the same method as mentioned in wiki. But i am getting error.

make CPULIST=x86 install
make -j 1 -Cnto-x86-o -fGNUmakefile install
make[1]: Entering directory `/home/vibi/fuse/qnx/qfuse/trunk/lib/fuse/nto-x86-o'
AR_HOST='ar -r' AS_HOST='gcc -c' CC_HOST='gcc -c -D__LINUX__ -D__X86__ -D__LITTLEENDIAN__' CL_HOST='gcc -D__LINUX__ -
D__X86__ -D__LITTLEENDIAN__' CP_HOST='/opt/qnx641/host/linux/x86/usr/bin/qnx_cp -fpc ' DATE_HOST='/bin/date +%Y/%m/%d-%T
-%Z' ECHO_HOST='/bin/echo' FL_HOST='/opt/qnx641/target/qnx6/usr/include/mk/flist-unix' GCC_VERSION='4.3.3' HOST_HOST='/
bin/hostname' INSTALL_ROOT_AR='/home/vibi/fuse/qnx/qfuse/trunk/install/x86' INSTALL_ROOT_ARSHR='/home/vibi/fuse/qnx/
qfuse/trunk/install/x86' INSTALL_ROOT_DLL='/home/vibi/fuse/qnx/qfuse/trunk/install/x86' INSTALL_ROOT_EX='/home/vibi/fuse
/qnx/qfuse/trunk/install/x86' INSTALL_ROOT_HDR='/home/vibi/fuse/qnx/qfuse/trunk/install/usr/include' INSTALL_ROOT_SO='/
home/vibi/fuse/qnx/qfuse/trunk/install/x86' INSTALL_ROOT_linux='' INSTALL_ROOT_nto='/home/vibi/fuse/qnx/qfuse/trunk/
install' KSH_HOST='/opt/qnx641/host/linux/x86/usr/bin/ksh' LD_HOST='gcc' LN_HOST='/bin/ln -sf ' MG_HOST='/bin/true' 
MKASMOFF_HOST='/opt/qnx641/host/linux/x86/usr/bin/mkasmoff ' MP_HOST='/opt/qnx641/target/qnx6/usr/include/mk/makepriv-
unix' PB_HOST='/opt/qnx641/host/linux/x86/usr/bin/phabbind' PINFO_DATE='2010/08/20-20:12:54-IST' PINFO_HOST='QnX-vibi' 
PINFO_STATE='automation' PINFO_TAGID='9999' PINFO_USER='vibi' PWD_HOST='/bin/pwd' QNX_HOST='/opt/qnx641/host/linux/x86' 
RM_HOST='/bin/rm -f ' TOUCH_HOST='/bin/touch' UM_HOST='/opt/qnx641/host/linux/x86/usr/bin/usemsg' USER_HOST='/usr/bin/id
 -un' VERSION_REL='testbuilds' QNXVFLAGS='' QNXROOTINCS='-I/home/vibi/fuse/qnx/qfuse/trunk/install/usr/include -I/opt/
qnx641/target/qnx6/usr/include' QNXROOTLIBS='-L/home/vibi/fuse/qnx/qfuse/trunk/install/x86/lib -L/home/vibi/fuse/qnx/
qfuse/trunk/install/x86/usr/lib -L/opt/qnx641/target/qnx6/x86/lib -L/opt/qnx641/target/qnx6/x86/usr/lib' /opt/qnx641/
host/linux/x86/usr/bin/ksh /opt/qnx641/target/qnx6/usr/include/mk/build-cfg install
Building for target: nto-x86-o  build:i386-pc-nto-qnx2.6.31-21-generic
checking build system type... Invalid configuration `i386-pc-nto-qnx2.6.31-21-generic': machine `i386-pc-nto-qnx2.6.31-
21' not recognized
configure: error: /bin/sh ../config.sub i386-pc-nto-qnx2.6.31-21-generic failed
/opt/qnx641/target/qnx6/usr/include/mk/build-cfg: error: configure failed
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/vibi/fuse/qnx/qfuse/trunk/lib/fuse/nto-x86-o'
make: *** [install] Error 2


Is this a known one ?

Thanks & Regards
vibi