Jump to ID:
QNX Foundation Classes

Project Home




Project Info
Forum Topic - QFC and Doxygen: (5 Items)
QFC and Doxygen  
After obtaining the QFC files from the repository following the directions at:  


and obtaining my plug-in of Eclox from http://download.gna.org/eclox/update 

I get the following message when I click on a Doxyfile.

"Unable to create this part due to an internal error. Reason for the failure: The editor class could not be instantiated
. This usually indicates that the editor's class name was mistyped in plugin.xml."

What do I do next to correct this problem?

Re: QFC and Doxygen  

I just tried installing Eclox from the link in your post, and it worked fine for me.  After installation, I double-
clicked on docgen.Doxyfile in the project "Ramdisk", and it opened the correct Eclox editor.

Did you restart eclipse after installing? 
Re: QFC and Doxygen  
BTW: I am preparing a major upgrade to QFC, that includes:

1. A dynamic plug-in class (i.e. a factory container that allows you to simply invoke a class constructor; under the 
covers this class will load the appropriate DLL, using a user supplied method to turn class name into a file name).

2. An adaptive partitioning class, that provides a basic framework for programmatic control/monitoring of temporal 

3. A SAT class that takes care of a lot of the trickiness of dynamic tracing.

Look for an announcement on the project page around the middle of July...
Re: QFC and Doxygen  
I found the problem.

I had gotten the Hot Eclox plug-in. This plug-in is only for 3.3 and higher.

Momentics is 3.2. Disabled Hot Eclox and now I can properly click on .doxyfiles.

Re: QFC and Doxygen  

I got the Hot Eclox as well, but it worked for me.  I am running the latest Momentics (ver 4.5 available here on F27) 
but AFAIK, it is still based on eclipse 3.2.  Anyway, glad it is working for you.

Have you installed dot as well?