Jump to ID:
Networking

Project Home

Discussions

Wiki

Project Info
Forum Topic - pf.conf and NAT: Page 1 of 16 (16 Items)
   
 
 
pf.conf and NAT  
REF: QNX 6.5

I'm pretty much tearing my hair out over this one.   I have a target board with two nics.  One will be visible on the 
internet and the other will have a NFS server.

The IP's are

host: fpx0:198.144.201.133 fpx1:192.168.1.1

NFS: 192.168.1.2

I want to be able to ftp through the board to the NFS server using ftp.   These are the things I've tried.

1) put a line in /etc/sysctl.conf
net.inet.ip.forwarding=1

I've also tried starting 

# io-pkt-v4-hc -ptcpip forward

The file /etc/pf.conf has the lines
rdr on fxp0 proto TCP from any to 198.144.201.133 port 21 -> 192.168.1.2 port 21
nat on fxp0 from 192.168.1.0/8 to any -> 198.144.201.133

I've also tried a number of variants on this.

Finally I load as follows:

# mount -Ttcpip lsm-pf-v4.so

And... nothing happens.  If I ftp from outside to 198.144.201.133 I get nothing if inetd isn't running, and if it is I 
get the ftpd on 198.144.201.133.   
I can always ftp from this machine to 192.168.1.2 and get the NFS server.

 #pfctl -s nat
gives the error No ALTQ support in kernel :-(.

A few side comments.
There are no error messages I can find generated by bad commands in pf.conf.
The documentation with 6.5 on /etc/pf.conf is dense and impenetrable.   I couldn't find anything to explain the 
occasional '!' inserted in a command.   To figure this out at all I had to google some UNIX docs.

Thanks for any assistance.