Jump to ID:
Multimedia

Project Home

Documents

Discussions

Wiki

Project Info
Forum Topic - A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2 : (4 Items)
   
 
 
A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2  
Hi,

Just wonder anyone can give me some hints about fail to play tracks from a USB stick on  a VMware target machine which 
running QNX neutrino 6.4.1 with Aviage MM 1.2. Details as follows:

After successfully built up a track session, and tried playing tracks on that, the MME delivery some error messages as:

MME_EVENT_PLAYSTATE
MME_EVENT_TRKSESSION
MME_EVENT_TRKSESSIONVIEW_UPDATE
MME_EVENT_TRKSESSION
MME_EVENT_PLAY_ERROR
MME_PLAY_ERROR_UNSUPPORTEDCODEC
MME_EVENT_PLAYSTATE.
MME_EVENT_PLAY_ERROR
MME_PLAY_ERROR_UNSUPPORTEDCODEC
MME_EVENT_PLAY_ERROR
MME_PLAY_ERROR_UNSUPPORTEDCODEC
MME_EVENT_FINISHED

From the above error messages, I couldn't figure out what caused the failure.

Then I tried using sloginfo (can see below for details):

Jul 23 02:48:43    5    20     1 io-media-generic: Received signal 15
Jul 23 02:48:44    5    27   200 MDP:mdp_mgr_init(264): Starting metadata plug-in initialization.
Jul 23 02:48:44    5    27     0 MME:dbs_init(469): Starting database synchronizer initialization.
Jul 23 02:48:44    2    19   900 devb-umass 1.00A (May 20 2009 17:07:26)
Jul 23 02:48:44    2     5     0 libcam.so (May 20 2009 17:06:08) bver 6040100
Jul 23 02:48:45    2     5   100 cam-disk.so (May 20 2009 17:06:11)
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: writer hint snd:* found
Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no video device 
specified.
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for -1 bytes, lw = 0, hw = 0.
Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no device 
specified.
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for 2116800 bytes, lw = 423360, hw = 
1693440.
Jul 23 02:48:47    5    20     1 io-media-generic/aoi: audio_writer using output device: '/dev/snd/pcmPreferredp'
Jul 23 02:48:47    3    20     1 io-media-generic/aoi: audio_writer snd_pcm_open_name failed: No such file or directory
Jul 23 02:48:47    4    20     1 io-media-generic/trackplayer: Couldn't find a suitable decoder filter, mmerr=4047
Jul 23 02:48:47    2    20     1 io-media-generic/trackplayer: Error 10004, 2, 4047:
Jul 23 02:48:47    2    20     1 io-media-generic/trackplayer: Couldn't create a linking filter for parsed stream
Jul 23 02:48:47    2    27     0 MME:_attachinput(3694): Could not attach input (/fs/usb0///
I'llBeMissingYou_PuffDaddy_withArtWork.wav) to co
ntrolcontext default (fid=1).  errno=5
Jul 23 02:48:47    2    27     0 MME:_play(3150): Could not attach file '/fs/usb0///
I'llBeMissingYou_PuffDaddy_withArtWork.wav'
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: writer hint snd:* found
Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no video device 
specified.
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for -1 bytes, lw = 0, hw = 0.
Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no device 
specified.
Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for 2116800 bytes, lw = 423360, hw = 
1693440.
Jul 23 02:48:47    5    20  ...
View Full Message
Associations:
post34473:
              Re: A question about fail to play tracks from a USB stick on VMware  by using Aviage MM 1.2 - Hello,
Please can anyone tell me how to check whther correct instance of audio running.I can find  /dev/snd/pcmPreferredp in /dev/snd path .But iam not able hear audio on  my speakers.

Thanks,
Santhi.  - kandregula vijaya santhi
            
Re: A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2  
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle 
> usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle 
> usage pid 3264525, tid 3!

These errors above mean that multiple threads have attempted to use the same MME connection handle at the same time. 
This isn't a good think, some of the MME calls have returned rc=-1 and errno EBUSY. Is this your application or just 
mmecli that did this?

> Jul 23 02:48:47    5    20     1 io-media-generic/aoi: audio_writer using 
> output device: '/dev/snd/pcmPreferredp'
> Jul 23 02:48:47    3    20     1 io-media-generic/aoi: audio_writer 
> snd_pcm_open_name failed: No such file or directory
> Jul 23 02:48:47    4    20     1 io-media-generic/trackplayer: Couldn't find a
>  suitable decoder filter, mmerr=4047

Well, since you don't have a /dev/snd/pcmPreferredp I'd imagine that must be your issue. Try starting "io-audio -
daudiopci" in VMWare first (not sure why it wouldn't have started automatically, are you sure you enabled the audio 
device in your virtual machine?)

Regards,
Gilles
Re: A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2  
>Date: Thu, 23 Jul 2009 03:44:11 -0400 (EDT)
>From: Chris Li <community-noreply@qnx.com>
>Reply-To: post34372@community.qnx.com
>To: general-multimedia <post34372@community.qnx.com>
>Subject: A question about fail to play tracks from a USB stick on VMware by
>    using Aviage MM 1.2 
>
> Hi,
>
> Just wonder anyone can give me some hints about fail to play tracks from 
>a USB stick on a VMware target machine which running QNX neutrino 6.4.1 
>with Aviage MM 1.2. Details as follows:
>
> After successfully built up a track session, and tried playing tracks on 
>that, the MME delivery some error messages as:
>
> MME_EVENT_PLAYSTATE
> MME_EVENT_TRKSESSION
> MME_EVENT_TRKSESSIONVIEW_UPDATE
> MME_EVENT_TRKSESSION
> MME_EVENT_PLAY_ERROR
> MME_PLAY_ERROR_UNSUPPORTEDCODEC
> MME_EVENT_PLAYSTATE.
> MME_EVENT_PLAY_ERROR
> MME_PLAY_ERROR_UNSUPPORTEDCODEC
> MME_EVENT_PLAY_ERROR
> MME_PLAY_ERROR_UNSUPPORTEDCODEC
> MME_EVENT_FINISHED
>
> From the above error messages, I couldn't figure out what caused the failure.
>
> Then I tried using sloginfo (can see below for details):

There is a PR in the system, that when an output device is missing, the 
error is returned on trying to attach to the input device. (which can lead 
to confusion as you've found) (PR 48932 for reference, at the moment its 
not prioritized as getting addressed soon)

Have your vmware session establish and audio driver to launch and confirm 
that you have a /dev/snd for the multimedia setup to play over.

I think you need to add the sound card as a device on the vmware session as 
it isn't automatically added.

Peter

>
> Jul 23 02:48:43    5    20     1 io-media-generic: Received signal 15
> Jul 23 02:48:44    5    27   200 MDP:mdp_mgr_init(264): Starting metadata plug-in initialization.
> Jul 23 02:48:44    5    27     0 MME:dbs_init(469): Starting database synchronizer initialization.
> Jul 23 02:48:44    2    19   900 devb-umass 1.00A (May 20 2009 17:07:26)
> Jul 23 02:48:44    2     5     0 libcam.so (May 20 2009 17:06:08) bver 6040100
> Jul 23 02:48:45    2     5   100 cam-disk.so (May 20 2009 17:06:11)
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:46    1    27     0 MME:ocb_lock(151): Concurrent MME handle usage pid 3264525, tid 3!
> Jul 23 02:48:47    5    20     1 io-media-generic/mmf: writer hint snd:* found
> Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no video 
device specified.
> Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for -1 bytes, lw = 0, hw = 0.
> Jul 23 02:48:47    5    20     1 io-media-generic/trackplayer: Skipping video subgraph because there is no device 
specified.
> Jul 23 02:48:47    5    20     1 io-media-generic/mmf: Configuring the queue for 2116800 bytes, lw = 423360, hw = 
1693440.
> Jul 23 02:48:47    5    20     1 io-media-generic/aoi: audio_writer using output device: '/dev/snd/pcmPreferredp'
> Jul 23 02:48:47    3    20     1 io-media-generic/aoi: audio_writer snd_pcm_open_name failed: No such file or 
directory
> Jul 23 02:48:47    4    20     1 io-media-generic/trackplayer: Couldn't find a suitable decoder filter, mmerr=4047
> Jul 23...
View Full Message
Re: A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2  
Thanks your info,  Gilles and Peter. 

It is all about the audio in VMware hasn't been set up, once I enabled the audio in VMware and checked there is a 
correct io-audio instance running on the target and in /dev/snd as well,  everything is working now.

Regards,
Chris
Associations:
post34372:
              A question about fail to play tracks from a USB stick on VMware by using Aviage MM 1.2 - Hello,
Please can anyone tell me how to check whther correct instance of audio running.I can find  /dev/snd/pcmPreferredp in /dev/snd path .But iam not able hear audio on  my speakers.

Thanks,
Santhi.  - kandregula vijaya santhi