Jump to ID:
Multimedia

Project Home

Documents

Discussions

Wiki

Project Info
Forum Topic - Fail to get album art info for 1st Gen iTouch by using mme_metadata_getinfo_current(): (2 Items)
   
 
 
Fail to get album art info for 1st Gen iTouch by using mme_metadata_getinfo_current()  
Hi,

It seems there is a problem of getting album art info for 1st Generation iTouch with firmware version 1.1.5 and 1.1.4, 
the error message return by MME_EVENT_METADATA_INFO is as follows: 

MME_EVENT_METADATA_INFO
ptMME_event_metadata_info->error = 22
ptMME_event_metadata_info->mdinfo_rid = 2
ptMME_event_metadata_info->metadata.len = 0

(ptMME_event_metadata_info is a pointer points to mme_event_metadata_info_t)

I am using mme_metadata_getinfo_current() with the asynchronous way to get album art, it works fine for other iPods. It 
looks like it could be the iPod issue, just wonder anyone have seen this problem before, thanks.

BTW, the Aviage I am using is version 1.2 build 20.14.

Regards,
Chris
Re: Fail to get album art info for 1st Gen iTouch by using mme_metadata_getinfo_current()  
> It seems there is a problem of getting album art info for 1st Generation 
> iTouch with firmware version 1.1.5 and 1.1.4, the error message return by 

Attempting to load artwork from iPod touches with FW 1.1.4 and 1.1.5 caused severe stability problems on the iPods. It 
was so bad that the iPod was rendered unusable until you did a hard reset on it. For this reason, a workaround was put 
into the iPod driver to fail all artwork requests on these iPods.

Apple corrected this problem in the 2.x FW version for iPod touch.

Regards,
Gilles