Jump to ID:
Multimedia

Project Home

Documents

Discussions

Wiki

Project Info
Forum Topic - ipod Authentication issue: (5 Items)
   
 
 
ipod Authentication issue  
Hi,

I am using the latest media package, when i connect the ipod I am getting the following error. Any help is appreciated


Thanks
Chiranjeevi
---> MediaService version : 4.4.11

Jan 01 00:07:00    2    10     0 Device not supported by this driver
Jan 01 00:07:00    2     6     0 Master send NACK
iPod timeout, lingo 0, cmd 5, value 2
iPod timeout, lingo 0, cmd 24, value 2
iPod timeout, lingo 4, cmd 11, value 2
iPod timeout, lingo 4, cmd 16, value 2
iPod timeout, lingo 4, cmd 17, value 2
iPod timeout, lingo 4, cmd 18, value 3
iPod timeout, lingo 4, cmd 1a, value 2
iPod timeout, lingo 4, cmd 1c, value 2
iPod timeout, lingo 4, cmd 1e, value 2
iPod timeout, lingo 4, cmd 28, value 3
iPod timeout, lingo 4, cmd 29, value 15000
iPod timeout, lingo 4, cmd 37, value 2
iPod timeout, lingo 4, cmd 38, value 2
iPod timeout, lingo c, cmd 12, value 2
Accessory maxsize is 1024
Status = 22
Jan 01 00:07:02    2     6     0 Master send NACK
Jan 01 00:07:02    2     6     0 Master send NACK
Jan 01 00:07:02    2     6     0 Master send NACK
Failed to open connection to io-audio
Status = 22
Failed to open connection to io-audio
Status = 22
io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Jan 01 00:07:12    5     3   800 io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Failed to open connection to io-audio
Status = 22
io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Jan 01 00:07:16    5     3   800 io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Failed to open connection to io-audio
Status = 22
io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Jan 01 00:07:21    5     3   800 io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Failed to open connection to io-audio
Status = 22
io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Jan 01 00:07:26    5     3   800 io-fs-media(IPOD(AUTH)): Authentication info error 0x8
Re: ipod Authentication issue  
First could you check your command line for io-usb? Make sure you are using "-c".

If the problem persists, could you please specify what "latest media package" is by posting the output of:
use -i io-fs-media
use -i deva-ctrl-ipod.so
use -i iofs-ipod
Re: ipod Authentication issue  
Thanks for the quick reply.
Yes there is a "-c" in the command line of io-usb.
I am attaching the conf files which i am using also.

And here are the version details: 

# use -i io-fs-media
NAME=io-fs-media
DESCRIPTION=Media IOFS Filesystem
DATE=2010/04/26-18:12:16-EDT
STATE=stable
HOST=spare1
USER=builder
VERSION=20.21
TAGID=3336@295193

# use -i deva-ctrl-ipod.so
NAME=deva-ctrl-ipod.so
DESCRIPTION=Driver for the IPOD.
DATE=2010/02/22-14:09:07-EST
STATE=experimental
HOST=mainbuild
USER=pspbuild
VERSION=641-1843
TAGID=3241

# use -i iofs-ipod.so
NAME=iofs-ipod.so
DESCRIPTION=IPOD Driver
DATE=2010/04/26-18:09:42-EDT
STATE=stable
HOST=spare1
USER=builder
VERSION=20.21
TAGID=3336@295193
Attachment: Text io_media_generic.conf 9.09 KB
Re: ipod Authentication issue  
Hello Tony,

I am currently working on the same issue.

Getting the following error:

io-fs-media(IPOD(AUTH)): ACP not available 16
io-fs-media(ipod): Failed starting ipod driver: Resource busy(16)

io-fs-media loads, but later io-audio fails to load.
If I do a pidin a the arguments for io-fs-media are as follows:

io-fs-media -dipod,transport=usb:busno=00:devno=01:audio=/dev/snd/ipod-00-01,darates=+8000:11025:12000:16000:22050:24000
,mount=/fs/ipod0,playback,acp=i2c,fnames=short,verbose=4

Let me know if I am missing anything.

Thanks
Lakshmi
RE: ipod Authentication issue  
Not suggesting that the following is the actual the root cause of your
issue but you may consider specifying the I2C address of the auth chip
explicitly as in:

io-fs-media -dipod,.....,acp=i2c:addr=0x11:path=/dev/i2c0,......


--
  Mate

-----Original Message-----
From: Lakshmi Boggaram [mailto:community-noreply@qnx.com] 
Sent: July 22, 2010 8:18 PM
To: general-multimedia
Subject: Re: ipod Authentication issue

Hello Tony,

I am currently working on the same issue.

Getting the following error:

io-fs-media(IPOD(AUTH)): ACP not available 16
io-fs-media(ipod): Failed starting ipod driver: Resource busy(16)

io-fs-media loads, but later io-audio fails to load.
If I do a pidin a the arguments for io-fs-media are as follows:

io-fs-media
-dipod,transport=usb:busno=00:devno=01:audio=/dev/snd/ipod-00-01,darates
=+8000:11025:12000:16000:22050:24000,mount=/fs/ipod0,playback,acp=i2c,fn
ames=short,verbose=4

Let me know if I am missing anything.

Thanks
Lakshmi



_______________________________________________

General
http://community.qnx.com/sf/go/post60244