Jump to ID:
Community

Project Home

Tracker

Documents

Discussions

Wiki

Project Info
Forum Topic - installing 6.4 in vmware: (12 Items)
   
 
 
installing 6.4 in vmware  
I'm having a problem installing native 6.4 install into vmware.  I've tried 

vmware server; install was successful, but photon could not be started

vmware workstation 6.5; install was successful, but when photon started, i just got a blank screen

vmware workstation 6.0.5; install was successful, but when photo started i just got a blank screen

My question is: what version of vmware should i be using for this?  

If it matters, I'm running vmware on linux instead of windows.

Thanks!

-garyf
Re: installing 6.4 in vmware  
I tried the live cd using vmplayer 2.0.4 build-93057 on my Linux box. Everything looks to be working so far, including 
USB - which is surprising since it is flaky with an xp guest.

The obvious questions are: 
 - do other guest OSes work correctly?
 - are the vm modules upto date with respect to the kernel?  
Re: installing 6.4 in vmware  
Hello Gary,

I use QNX 6.4 M7 and QNX 6.4 M8 inside VMware Workstation 6.0.4 build-93057.

I didn't have any problems with photon. Even 16:9 resolutions (e.g. 1680x1050) are working fine.


Best regards

Matthias
Re: installing 6.4 in vmware  
FWIW on my Dell Latitude D830 laptop running Fedora 9 and VMware Server
1.0.7 build-108231 I can only get Photon running on the laptop screen.
Using an external monitor is tricky, at best.  It usually starts up OK
at 640x480 but any attempt to change causes a black screen and an
apparent hang.

On Thu, 2008-10-23 at 17:30 -0400, Matthias Klein wrote:
> Hello Gary,
> 
> I use QNX 6.4 M7 and QNX 6.4 M8 inside VMware Workstation 6.0.4 build-93057.
> 
> I didn't have any problems with photon. Even 16:9 resolutions (e.g. 1680x1050) are working fine.
> 
> 
> Best regards
> 
> Matthias
> 
> 
> _______________________________________________
> QNX Software Development Platform 6.4.0 Pre-Release
> http://community.qnx.com/sf/go/post15483
> 
Re: installing 6.4 in vmware  
Oops.  I just realized I conflated two different scenarios there.  (Faulty wetware apparently...)

Running the livecd directly (no VMware) on my laptop with an external montor causes the black screen and hang grief.  
I've never managed to get anything other than a photon error when running under VMware server.  One hint I was given is 
that it may have something to do with the desktop colour depth, so maybe try fiddling with that?

Regards,
Neil
Re: installing 6.4 in vmware  
I just installed vmware 6.5 with QNX 6.4.0, and all I get for photon is "unable to start graphics driver(s)" I editted /
etc/system/config/display.conf to comment out all but the vmware driver to no effect. Any other things I should be 
trying? Has anyone gotten this combination to work?
Re: installing 6.4 in vmware  
That is "vmware workstation 6.5"
Re: installing 6.4.0 in vmware workstation 6.5  
To answer my own question, I found the hint I needed in the VMWare project support forum. I needed to edit display.conf 
and change the pixel format line in the vmware stanza to read 'pixel_format=rgb565'. Now I appear to be good to go with 
a vanilla installation of 6.4.0 on vmware workstation 6.5.
Re: installing 6.4.0 in vmware workstation 6.5  
What color depth is your host running at?   QNX 6.4.0 has the VMware driver default to 32-bit (ARGB8888) with the 
assumption that Windows is running in 32-bit.

RE: installing 6.4.0 in vmware workstation 6.5  
I've never had to fiddle with config files to get QNX to work in vmware

> -----Original Message-----
> From: Michael Van Reenen [mailto:community-noreply@qnx.com]
> Sent: January-21-09 10:14 AM
> To: sdp640prerelease-community
> Subject: Re: installing 6.4.0 in vmware workstation 6.5
> 
> What color depth is your host running at?   QNX 6.4.0 has the VMware
> driver default to 32-bit (ARGB8888) with the assumption that Windows is
> running in 32-bit.
> 
> 
> 
> _______________________________________________
> QNX Software Development Platform 6.4.0 Pre-Release
> http://community.qnx.com/sf/go/post20494
> 
Re: installing 6.4.0 in vmware workstation 6.5  
Hi Mike,

I tried to switch from 32 bit to 16 bit color depth on a Windows machine here and QNX 6.4 in VmWare failed to start 
Photon.

- Malte
Re: installing 6.4.0 in vmware workstation 6.5  
Did you change your display.conf to have the pixel_format=rgb565 
for vmware?

After changing the Windows color depth I believe you may have to re-start VMware (or at least your VMware image)

----------
Mike